What are the minimum requirements for the Oritor Conferencing client?

Users need a web browser capable of running Flash or webRTC. To check the version of flash, visit Adobe’s Flash Version Check page.

If a Mac user is running an out-of-date version of Flash (Oritor will check the version of flash), they can upgrade by visiting the get Flash player page at Adobe.

To run the desktop sharing, the presenter (and only the presenter) needs to have a Java runtime. You can test that Java is installed by visiting Java Test Page (there are download links on this page if you need to install Java). For bandwidth, we recommend 1Mbits download and 0.5 Mbits upload speed. Users can test their actual bandwidth using speedtest.net.

For hardware, we recommend a Dual-core CPU with at least 2G of memory. For Mac, we recommend any Mac running Mac OS X operating system.

Posted in: Technical